Ecshop模板网
ecshop模板制作二次开发插件教程网
共363套模板插件、1920篇文章教程
首页 > ecshop教程 > ecshop安装使用 > ecshop报错gd_version() should not be called
文章详情

ecshop报错gd_version() should not be called

ecshop模板网 / 2013-12-23

ecshop出现Strict级别错误:
Strict Standards: Non-static method cls_image::gd_version() should not be called statically
includes/lib_base.php文件中的gd_version()函数


includes/lib_base.php文件中的gd_version()函数中搜索:
return cls_image::gd_version();

修改为:
$img = new cls_image();
return $img->gd_version();

当然也可以在cls_image类中将gd_version方法定义为静态的。

如果错误还存在,记得后台清除缓存。

此函数是直接静态调用cls_image类中的gd_version方法,原始代码:return cls_image::gd_version();因为cls_image类中的gd_version非静态方法,这样调用会出现Strict级别错误:

下一篇: ecshop报错lib_main.php on line 1329 上一篇: 安装Ecshop首页出现报错:Only variables should be passed by referen
 用户评论(共 0 条评论)
  • 暂时还没有任何用户评论
用户名: 匿名用户 E-mail:
当前心情:
评论内容:
验证码: captcha
返回顶部 返回首页